Unable to add my Synology NAS

Tailscale version
1.16.2.2013
Your operating system & version
Windows 10 Home 21H1 19043.1415

When I first established my TailScale Account and added my Cell Phone plus my Synolgy NAS running DSM 7.0.1-42218 all was well. Subsequent I removed my iPhone and NAS from my TailScale network. Today I attempted to add back my Phone and the NAS … The Phone added in without issue but I am not able to add back my NAS, When I run my Synology TailScale App I get the login screen but nothing happens when I attempt to log it in except the following message:

Failed to log in: Failed to fetch

I tried to uninstal and reinstall the TailScale Synology app but the login still failed to work … is there a solution to this please. Thank You.

So I am going a Synology Reset … from what I learned that is the only way to get it to work. Will report back soon.

That shouldn’t be necessary: the tailscale state is in /var/packages/Tailscale/, removing that directory might be enough.

1 Like

Thanks for the suggestion … but its to late :roll_eyes: the reset worked and now I successfully added in the NAS.

BTW what are the steps in removing that directory for the next time I mess up :grinning_face_with_smiling_eyes:

You would need a shell where you can type commands, and then rm -rf /var/packages/Tailscale/

1 Like

Thank You … very helpful

I just tried that and the package uninstall function of Synology already deletes that folder.

I am having the same issue. The first time I installed Tailscale on two of my synology devices, it worked perfectly fine, but after uninstalling and re-installing, now the login in button does nothing. I am not going to reset my nas devices so I am looking for a workaround.

All of the files I see change on my DSM7 NAS are in these folders:

/volume1/@appdata/Tailscale
/volume1/@apphome/Tailscale
/volume1/@appconf/Tailscale
/usr/syno/etc/packages/Tailscale
/var/cache/pkglist.tmp/icon/AVAIL/SYNO/Tailscale
/usr/syno/etc/packages/SecureSignIn/preference/tailscale

2 Likes

Have you tried V1.20.3?
https://pkgs.tailscale.com/stable/#spks

I just installed 1.20.3 manually and the Log In button still doesn’t do anything.

Something must be left behind from the first installation that is causing this issue, because it worked just fine the first time.

Unfortunately one of my NAS units is remote so I don’t have ssh access. I hope I don’t have to use ssh to do anything to resolve this issue.

I have to give up on Tailscale for now until this issue is resolved. Too bad.

Thanks for this Jay, this is really useful. I’ve had the same issue surrounding installing Tailscale on my synology. I have deleted all the folders you have listed and I will test to see if Tailscale can be installed brand new again.

Dear all

So I can confirm that I have got mine to work correctly again after following the command and deleting the following folders recommended. I am using DSM 7 and now it work prefectly again.

2 Likes

Hi everyone -

I made an account here to share with everyone how I solved this issue. I was getting the same error and spent an evening trying to figure this out lol.

First, SSH’d into your Synology
Then run the command ‘sudo tailscale up’. Terminal then returns a custom URL which I was able to paste into my browser where I was allowed to log into my Tailscale account. From there everything was authenticated and is now running as it should on my Synology.

Hope that helps someone!

5 Likes

Registered just to say thanks for this fix. Had the same issue and worked perfectly :100:

Thanks Dean, i registered just to say thanks also. I wasn’t prepared to reset the NAS but your instructions worked perfectly.

1 Like

Thanks a lot for posting this lead - you’ve saved me from giving up on running Tailscale on my NAS!

One extra step I have taken to make sure this authorization did not fall apart once again is disabling key expiry for the node (using the Machines page in Tailscale web UI).