Potential issue with DSM 7.1.1-42962 Update 3?

Hi :slight_smile:

I use Tailscale on several devices, including some Synology NASes. All my NASes run DSM 7.1.1-42962 Update 1 and Tailscale 1.30.2.

The only exception is 1 NAS running DSM 7.1.1-42962 Update 3 (and Tailscale 1.30.2.).

Recently (I suspect since the upgrade from DSM 7.1.1-42962 Update 1 to Update 3), this NAS can no longer connect to other devices using their TailscaleIP (I only tried in hyperbackup, though). target is unreachable.

I contacted Synology but they are not very helpful and suggest the issue comes from Tailscale.

Is there any known issue with Tailscale and DSM 7.1.1-42962 Update 3?


Did you try following the instructions here?

Access Synology NAS from anywhere · Tailscale

I have this issue also. I followed the instructions above precisely. (Firewall not enabled) and after restart, I only get to the package, it shows installed. I click on log in and get to a new tab with login - and either nothing happens - or if I wait a minute or two I get, “Failed to log in: Failed to fetch”.
DSM 7.1.1-42962 Update 4
MacOS 13.2.1
Chrome allows pop-ups

Dead in the water here wrt Tailscale on my DS415Play.

Tailscale WAS working about 2 weeks ago last time I went to use it from a remote location.

OK - THIS fixed it for me. I used my Macbook and logged in to the tailscale admin console from the TS icon. Click on the icon - highlight your name / account and the second item down in the popup menu is “Admin Console.” Once there you see a list of machines on your TS account. The DiskStation had something like “key expired” under it. I went to the 3. dots on the far right and clicked. I saw “temporarily extend key.” I clicked that and got 30 a minute extension. Great… except I’d like more than 30 min more using tailscale. While there are ways to get 90 day keys in etc. I played with it - then I stumbled across clicking on the same three dots on the far right. A new option was there. “Disable Key Expiry.” I clicked that and now my key doesn’t expire and my diskstation no longer needs to reauthenticate to remain on my TS network! FTW!

I had checked that already but in my case I had already disabled key expiry…

Since I couldn’t find this topic for a while I made another one here:

sorry for the duplicate.

I gave more details on the other one though :slight_smile:
" Hi :slight_smile:

I’m kinda new to Tailscale and, a few months ago, I set it up on 2 Synology NAS at home (DS1819+ and DS1821+) so that they can perform weekly backups to a Synology NAS at work (DS918). The NAS at work is behind a closed LAN and requires VPN to connect to, hence Tailscale… I also set up Tailscale on 2 additional NASes at home (DS414 and DS214play).

Now, for a few weeks, everything went well and offsite backups occurred without any issue. All of a sudden, one of the NAS at home (DS1821+) could no longer reach the NAS at work (DS918), while the 2nd NAS at home (DS1819+) never experienced any issue and still continues to perform its weekly backup as usual.

At first I thought this could be due by an incompatibility between Tailscale and the latest version of DSM since the DS1821+ was recently upgraded to DSM7.1.1 Update 3 while the DS1819+ was running DSM7.1.1 Update 1 (update 3 was not even offered as an update). FWIW, the DS918 is still running some earlier version of DSM7.0.1.

However, this is not the case since I noticed the following:

  • the recent upgrade to all my NASes to DSM7.1.1 Update 4 didn’t fix the problem for the DS1821+ and didn’t cause the issue to appear on the DS1819+ either.
  • 2 other NASes at home (DS414 and DS214play) also run Tailscale but can neither reach the NAS at work (DS918).

I also know the problem is not coming from the DS1821+ since it can perform backups on the DS414 using Tailscale IP without any issue. And, again, neither the 414 nor the 214play can reach the 918 for some reason…

All NASes seem to be properly connected according to what I can see in Tailscale admin console.

I’m probably missing something here but I hope some of you can share their knowledge and wisdom :slight_smile:

Thank you very much in advance for your help.

Is it possible that for some reason, at some point, TailScale (TS) would only let me connect to the DS918 using its TSIP from only one client (here from the DS1819+)?
I mean is there such a limitation in the free version of TS?