Windows/Synology/SMB issue

I have a Synology NAS offiste that has Tailscale directly installed on it. I am using SMB to connect to it.

When I try to transfer large files to a Windows PC, it starts, but then slows to 0 KB/s and eventually fails.

When I do the same thing from Linux it works fine.

I went to the site today and directly connected to the NAS via the local network (In other words, I didn’t connect through Tailscale), and it worked fine as well.

Is there an issue in the latest version of Tailscale and either SMB or Synology? (I believe I am on 1.40.0 on all devices in the chain).

Any help would be great.

Hello muzicman0,
I had the same type of issue when doing that a week ago, but my internet connection was quite bad.
I gave out because it was not important.
Have you tried to download your file using filestation from synology ?

Let me know if it works well.

Yes, I did try that, and originally I thought it was going to work, but it failed as well. I have tried from 2 different locations that fail (office and home). It works from the office if I use Linux, but not Windows. It also works if I go to the school where the NAS is, and connect directly to the network there.

Is Firewall enabled on the Synology NAS?
Can also try disable auto-block and disable DoS protection see whether it will help.
Or try adding the NAS IP address to the list of trusted proxies?

Firewall and DoS isn’t enabled. I can try the auto block, but the connection isn’t being blocked. I can immediately start the transfer again, and it will start again, but fail after a few seconds.

Again, Windows on the local network (technically, a different VLAN, but NOT through Tailscale), and Linux on a remote network seem to work fine.

I’m installing another Linux VM at my home, and I will see if it will transfer to that PC. The VM will be hosted on a PC that it won’t finish the transfer to. I know that SMB on the Synology was just updated, and I am wondering if there is a problem since I am 99.9% sure that I have transferred these files over Tailscale in the past to this PC.

I may also try NFS just to see.

The VM using SMB seems to be fine. Transfer isn’t actually finished yet, but it is well past the point it would have failed on the Windows host. So weird.

To recap:
I can’t transfer a large file to my Windows i9 PC, running Windows 11 Pro from a Synology NAS. It starts, then slows to 0 Mbps x-fer speed after a few seconds, then fails roughly 30 seconds later.

However, I installed a Linux VM on that SAME i9 PC that it fails to transfer to, and it is working fine.

It does appear to be Tailscale related. I created another VPN from the Unifi network where the NAS is and used it to test SMB to the NAS, and it is also working fine. So the common denominator here is Windows (11?) and Tailscale.

Just to check - you said that the version of tailscale in Synology NAS is 1.40.
I tried mine (package)and it seems to be 1.30?
Unless you are using Docker or something…

I update manually. So I am at 1.4. You can download the install file from tailscale.