Getting two Synology NAS to talk

Hi all.

Up until a few months ago I had Tailscale working at both ends on two Synology NAS in two different locations.

This was great as it let me backup via that instead of less secure port forwarding rules. Then it broke and I couldn’t figure it out so I gave up.

Fast forward to today and I have tried for about an hour to get this working again. Below is the list of things I have tried so far.

  1. Removed the app from both Synology nas and removed the devices from the admin console.
  2. Installed from the package centre and re-authenticated both Synology units
  3. Upgraded them to the stable package on GitHub bringing them both to 1.32.x version
  4. Read through the Synology installation page and noted the caveat about it blocking outgoing connections
  5. Ran the commands from that installation page three times on each device and setup the scheduled task for boot and run that three times as well

I cannot ping each NAS from the other no matter what I do but I can reach the web interface of both NAS machines from a third machine confirming that they are atleast on the Tailscale network.

Now it seems to me that the issue is still the outgoing connections but I cannot see how running the commands again would resolve the issue.

I am pretty sure this is user error on my part but I don’t know what I have done wrong and happy to take suggestions.