Synology Replication DSM to DSM over TailScale Internet

So, I have 2 Synology DSMs at 2 locations. TailScale is installed on both via the Synology Package center. Both units are showing Live on the TailScale management page.

When trying to establish Snapshot Replication, I entered the TailScale IP addresses as listed on the TailScale management page.

The Sending unit is on a StarLink device. It uses CGNat. Carrier Grade Nat.
I was hoping TailScale could get me around this.
Probably something simple that I don’t know.

Is this even possible? Snapshot Replication over Tailscale. DSM to DSM.
Thanks in advance.

Further investigation:
I can’t ping either address, local or remote from the SSH CLI.
I suspect I need to bind the local address to the local Ethernet. Just guessing.

More Further:
sudo tailscale ping x.x.x.x does in fact ping the remote address.
Getting closer. I’ll allow these addresses through the firewall on the DSM.

Installed TS version on the DSMs is: 1.38.4-700038004

Still no Joy.
Perhaps Monday workday will bring someone that knows.
Or Tuesday, non-holiday.

Wednesday. Still no joy.
I have been able to use my PC to attach to the remote DSM and Robocopy the files to my home office.
Not the optimal solution, but it does get the files Off Site.

DSM should log into DSM directly. My other sites all do this.

Using this: Synology DSM7 Cant ping External (already ran steps) · Issue #4928 · tailscale/tailscale · GitHub

  1. sudo /var/packages/Tailscale/target/bin/tailscale configure-host
  2. sudo synosystemctl restart pkgctl-Tailscale.service
  3. sudo chmod 755 /dev/net/

Not only can I ping from DSM to DSM, but the SnapShot Replication now sees the other side and is established.

Starlink CGNat was the issue. Bypassed the Routers and Firewalls completely.

Hey Holder!! How are you doing?

Pretty good. How about you?

So, why are you talking to yourself?

I seem to be the only person here.
And at least I get expert opinions and no wise cracks this way.