Windows 10 - 1.14.4 -> 1.16.0 Upgrade - Backend Error

I was upgrading to 1.16.0 today on a Windows 10 machine (from 1.14.4) and got this error right after. Have never seen this one before. I did NOT exit the Tailscale app or stop the Tailscaled service prior to upgrading, but I have never done this for past upgrades.

Fix was easy enough. I had to stop the Tailscaled service, make sure nothing Tailscale* was showing up in Task Manager, then I just reinstalled.

Just throwing this out there for awareness. Will test on another Windows machine later today.

Tailscale Error

Tailscale backend error:
GotNotify: Version mismatch! frontend=“1.14.4-t682d4a31e-g910f31d07” backend=“1.16.0-t86bcf6a96-gf787a582e”

Just wanted to add to this that this is a common issue on a number of my Windows machines today. It seems to come up when unattended mode is on and there is another Windows user logged in. I always upgrade Tailscale from the same account it was installed, but almost every time on these machines, after the install, I get a backend mismatch error. The only way to fix is manually stop Tailscale service and reinstall. I dont lose credentials or anything, but it does make a quick upgrade a pain sometimes when remote. It seems like the machines with a single user upgrade just fine, but can’t prove this.

We have filed a bug for this behaviour. Thank you for bringing it to our attention.

HI @gregg098

One of our engineers would like to know if you’re using the MSI installer or not. You can comment here or on the GitHub issue linked above. That will help us reproduce the error.

I click the upgrade notification in the app which auto downloads the new version, so yes, the MSI installer.

We don’t download the MSI from the upgrade notification, so it’s probably not the MSI.

What’s your Tailscale IP address? (it’s safe to share publicly)

You’re right. Just noticed there is a new update available and it downloaded an exe installer.

To test, I RDP’ed into one of my Windows machines as a different user. Left that user logged in and disconnected. RDP’ed back in as my main user and tried to install. Right as it finished, I got the message below.

Before I did anything else, I ran tailscale bugreport.


Logged out the other user, re-ran tailscale-ipn-setup-1.22.0.exe, and it installed properly.

This machine’s IP is

Just to re-summarize a few things that might help:

  • Windows 11 - I did have it happen once on Windows 10 I believe, but its been awhile
  • Running in unattended mode
  • It appears this only happens when another user is logged in, but inactive
  • Has happened on multiple Windows machines for me. One is an old Dell, another is a KVM on Proxmox.

Let me know if you need anything else.

I had the exact same issue as the post above. I resolved it by closing all the users that were signed into Windows (ie not logged out), restarted, and that resolved the issue.