Windows upgrade to 1.14.4 fails

When upgrading to 1.14.4, I started to get following error message and not sure what to do (besides re-installing the whole thing).

image

And let me answer my own question. For some reasons, Tailscale service refused to die during the update (was spinning itself up all the time) so I guess that prevented the upgrade of the front-end. By manually stopping the service and then applying the new install package, the system started to work again.