Having trouble running Tailscale on UbuntuServer: Version mismatch

Hey there, I’m having some trouble running tailscale in one of my machines, it’s a server Ubuntu (server) 20.04.3 LTS.
Whenever I run tailscale up I get:

Warning: client version "1.20.2-t312750ddd-g2c164d9c7" != tailscaled server version "1.20.1-t6dbdbb41a-g41b221f94"
2022/01/26 21:31:39 GotNotify: Version mismatch! frontend="1.20.2-t312750ddd-g2c164d9c7" backend="1.20.1-t6dbdbb41a-g41b221f94"
backend error: GotNotify: Version mismatch! frontend="1.20.2-t312750ddd-g2c164d9c7" backend="1.20.1-t6dbdbb41a-g41b221f94"

I tried uninstalling with apt purge tailcale and reinstalling with the “autoinstall” script running curl -fsSL https://tailscale.com/install.sh | sh but nothing works.
I looked online to see if there was any other person running the same problem, but it seems an isolated case. I don’t know what to do now.
Thanks in advance to everyone.

It looks like there is somehow another tailscaled binary elsewhere in the filesystem which is running. It might have been installed manually, but it does appear to be running the 1.20.1 release binary since 1.20.1-t6dbdbb41a-g41b221f94 is the build from Tailscale.

I’d recommend:

  • apt remove tailscale
  • which tailscaled
  • whereis tailscaled
  • ps auxw | grep tailscale

Basically we’re looking for whether there is a 1.20.1 still on the system somewhere.

1 Like

That was quick haha, thanks a lot, definitely worked.
It seems like I had some process running, (Honestly I’m just starting with Linux), ps auxw | grep tailscale gave it away, running that outputted this:

root        1800  1.2  0.1 720116 22348 ?        Ssl  13:06   6:52 /usr/sbin/tailscaled --state=/var/lib/tailscale/tailscaled.state --socket=/run/tailscale/tailscaled.sock --port 41641

I just ran sudo kill -9 1800 and reinstalled tailscale with the autoinstallation script.
Now it’s working perfectly.
Thanks again, have a great week.