Tailscale only works on local network

Complete noob here and not very knowledgeable networking wise so please be gentle!

I have installed Tailscale on several devices - 3 Macs of varying ages and OSX versions from Catalina to Ventura, a Windows 11 machine, a Raspberry Pi, a Synology NAS, and two iOS devices.

I find that I can successfully ping the RPi and Macs, and vnc to the Macs, but only on the local network. As soon as I try to do this when not connected to the local network, e.g. via mobile hotspot, these don’t work. I haven’t tried http to the NAS.

Am I missing something, is there something I need to change? I was of the understanding that it should just work, and all the videos I’ve watched and things I’ve read seem to suggest it should.


Okay, I seem to be working my way through these problems I’m having.
The problems I was having with not being able to ping other clients on my Tailscale network from outside my local network seems to be due to the app I was using on my iPhone. Tried a different app and now okay.
I can also SSH to the RPi on an iPad and terminal on a Mac from outside my network.
Remote Desktop also now working from outside the local network.