Tailscale on Debian server with Docker Compose

I currently have Tailscale on Debian server with Docker Compose. I can remotely ping my debian server with magic dns or it’s tailscale IP address. When I enter either one of them to access a local docker such as tailscaleIP:4000 it returns with an error. I however have I a broken 8096 (jellyfin) pulling up asking me to connect a server, which is unusual.

  • To run my docker compose I run $ sudo docker compose up -d #am I missing anything for tailscale?
  • There are currently no exit nodes on my tailscale.
  • There are no subnets on my tailscale
  • tailscale status # works as expected

inspect your docker network to see the adapter settings used
Depending what kind of network type u use you may or may not able to ping the host.
For example if u chose a macvlan, then the host is segregated from the network.
Also make sure tailscal is set to allow local network access.

1 Like

Thanks for replying Kukabuvar,

Will explain my work flow for my future self and other’s struggling as well.

I’ve made some progress as you’ve hinted at using the server with the hosted docker compose as an end node which actually lead me to enabling advertising routes, exit node, and accept routes. Example $ sudo tailscale up --accept-routes --advertise-routes=, --advertise-exit-node

I created a subnet and that allows me to access protainer and a few other VM’s but I’ve noticed that my docker compose is still not working. Just as you suggested it pointed to the VM’s network card.

Currently on promox debian VM is using bridge:vmbr0 model: VirtIO (paravirtualized) and tested firewall off and on. Then I downed the Debian VM to change the network card to one of the other 4 options that wasn’t VirtIO. Intel E1000 was on the top of the list and was the first one to make everything work as intended.

Thanks again Kukabuvar!