On Debian, after "tailscale up" I can no longer access via 192.x IP

I have trouble understanding why I can’t access my raspberry Pi on Debian 12 (also, Debian 11 failed as well) but works on Ubuntu. I am missing some piece of advice that I can follow to understand how to make it work.

server A can access server A via 192.x IP without issues:

milan@ixion ~ → ip addr show
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether e4:5f:01:0b:84:e2 brd ff:ff:ff:ff:ff:ff
    inet brd scope global eth0
       valid_lft forever preferred_lft forever
4: tailscale0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1280 qdisc pfifo_fast state UNKNOWN group default qlen 500
    inet scope global tailscale0
       valid_lft forever preferred_lft forever

milan@ixion ~ → ssh
The authenticity of host ' (' can't be established.
ED25519 key fingerprint is SHA256:7bWrTcOMUMyssg+8T2nEcztSXaBJPGFgE/HolU1/cIQ.
This key is not known by any other names.
Are you sure you want to continue connecting (yes/no/[fingerprint])?

On any other server, with Tailscale up (or down) locally:

... times out

Now, if I turn off tailscale on server A, everyone can access server A using 192.x IP.

I have subroutes set up correctly and they work correctly I think:

  1. each other server (except A) have “–accept-routes=true”
  2. one other server has “–advertise-routes= --accept-routes=true” and I have enabled routes on login.tailscale.com.

If I can help by providing more information, please don’t hesitate to ask :slight_smile:

I think this is a known issue. I was having this same issue until i added this to the ip table “ip rule add to priority 2500 lookup main”. Take a look at the end of this guide, it may help… Troubleshooting guide · Tailscale