Subnet DNS Not resolving

So I had everything working fine, but then I saw there was an upgrade and I had to uninstall Tailscale and reinstall it to get the upgrade… now DNS is broken!

Running Truenas Scale - Tailscale in an application, V 1.36.2

I have subnet setup for “” and approved - I can access the network by IP address, but now all of a sudden I’m unable to access it by hostname - for instance “” works, but “http://Truenas” doesn’t work. Its been working fine for 2-3 weeks, and on 5 different PCs… now its broken on all.

Now if I use the DNS of something that actually has tailscale installed on it… IE Truescale, and ping truescale then it’ll come back with the tailscales IP address for true scale (100.x.x.x, etc) - So it seems to resolve items on tailscale, but not items on the local network.

I even tried to setup subnet on a windows PC - Same thing… I can get it to work Via IP but it wont resolve names.

Use tailscale DNS / Subnets is checked off on all the machines - but it doesn’t seem to be revolving any of the local network names.

As a last resort Ican just edit the hosts file, but I’d rather not as I’d like access to every device on the network.

Hoping I just missed something… it was working great when it worked! Any help is appreciated