Sometimes machine not reachable in Tailscale network

We have a Home Assistant instance running in the office. I use Pixel 5 on latest Android to access it and it works fine.

However a couple of colleagues use Mi 3 (Android 11, Tailscale 1.16.1) phones and once or twice a week they notice that it is not possible to reach Home Assistant via Tailscale (we use Home Assistant to open gates).

Usually the workaround is to turn off Tailscale and turn it back again. That does not always fix the issue, but after a couple of toggles it starts working.

What information would be useful to report from an Android phone when we notice Tailscale network not reachable next time?

1 Like

On the desktop platforms it is possible to send a bugreport which helps locate telemetry to focus on, but this doesn’t fit in the UI of the mobile device platforms.

As exact a timestamp as we can get, with timezone, along with the Tailscale IP address of the device which cannot connect would be most useful.

The ideal would be if the device works, and then a short time later does work, as it gives us a relatively small amount of telemetry to dig through looking for clues.

Okay. So here is the timeline and more details from yesterday.

Couple of minutes before 2021-11-11 11:50 UTC Pixel 4a device with Tailscale account0 having IP address 100.102.1.100 was not able to access Home Assistant device on Tailscale account2 having address 100.86.200.46.

Shortly after we tried to reach the same Home Assistant from Mi 3 android device with Tailscale account1 having IP address 100.76.192.2. That was also not successful. Then we tried to toggle Tailscale connection off and on in the Tailsale app. After first toggle Home Assistant was still not reachable. After second or third try connection to Home Assistant started to work.

account2 has Home Asisstant device shared with account0 and account1 via Tailscale Admin panel.

We are working on the internal issue which has the same symptoms as you described in your email. We will notify you once this issue is fixed and then you can try again.

2 Likes

I am seeing a similar behaviour. Was the fix implemented ?

Would you please try Tailscale version 1.18.1? if you still see the issue, please share the tailscale bugreport when issue happens and the Taiscale IP of both ends on support@tailscale.com

I noticed this issue just now again. Mi 3 android device with IP address 100.76.192.2 was not able to access 100.86.200.46.

However it worked just fine from Pixel 6 device with IP 100.84.173.88.

those devices do not appear to be connected to the same tailnet

If you want to access devices on different tailnets, you would have to use node sharing. We have some documentation on that here: Sharing your nodes with other users · Tailscale

Yes, these devices are on different Tailscale networks. But I have shared the device with other users in the Tailscale admin panel.

OK, I see that now.

Can you currently access the shared node from any other tailscale node? If so, can you try again on your node, and send us the time (and time zone) when you made the attempt, and I can check our telemetry.

So yesterday, maybe around 10 minutes before my first post the shared node 100.86.200.46 (linux) was not accessible from my friends Mi 3 100.76.192.2 but I was able to access it from my Pixel 6 100.84.173.88.

As near as I can tell, the Mi3 was not connected to tailscale at that point in time.

If you’re able to run tailscale bugreport on the linux node as close as possible to the time that you can’t connect, and send the code to support@tailscale.com along with the tailnet ip of the device(s) that can’t connect, then that will help narrow it down.

I see. Thanks a lot. I will do that next time this comes up.

So I think I have more information regarding this. We did a bit of shuffling around of devices during the holidays. :slight_smile: And now, the device that I was daily driving before and did not ever have problems accessing devices on the Tailscale network, is having troubles.

So I never had problems accessing the Home Assistant Linux device from my Android phone when both of these devices are on my Tailscale network.

But then I gave the same Android device to another person who uses their own Tailscale account, and now they have problems accessing the same Linux device on my Tailscale account. The device is shared and no ACL rules are configured other than the default ones.

So to test my hypothesis that this problem only happens with shared devices, I have created another Tailscale account for using on my phone - Pixel 6. I have also shared the previous Linux device that runs Home Assistant and Tailscale with this new account.

It was working fine for a couple of days, but today I was able to reproduce it - Linux device running HA was not accessible from my phone.

My phone Tailscale IP: 100.79.21.60
Linux Home Assistant Tailscale IP: 100.86.200.46

Just to reiterate, both of these devices are on different Tailscale accounts, and the Linux device is shared with the account that is running on the phone. No ACL rules are configured.

In fact, I tried accessing other Tailscale devices, that are also shared with this new account, none of them were accessible. Their IP addresses: 100.126.64.38 and 100.66.50.92.

I tried toggling “Active” toggle in Tailscale app, but that did not fix the problem. What fixed it, was going to Android VPN settings and disconnecting from Tailscale VPN there. Then after starting Tailscale app, everything was working.

While it was not working I used “Bug report” functionality in the Android app and got the following string: BUG-1657bdc6b466e24c67c381f3f21f2759c96bde9a75e92b124fe7b69b694d3fe0-20220114170741Z-532dae20e4295658.

I’m looking at the telemetry for that HA device, and around the time that that bugreport was generated on the Android, the HA machine had 0 network traffic to tailscale.

Based on the logs, it looks like it lost connectivity, either to the tailscale telemetry servers, or internet access completely.

Between 15:24 and 19:11 (+0200) on the 14th, there’s no traffic to/from the HA node
Hopefully that offers a clue. Do you have any other services running outside of tailscale that might have logged a loss of connectivity during that window?

I see. What is interesting, is that on 19:11 (+0200) I have disabled and enabled Tailscale VPN on my Android device and that fixed the connectivity to the HA device and other two devices that are shared with the Android device.

So the issue seems to not be on the HA device side, but on the Android?