Activating --accept-routes disables local ip access

Tailscale version: 1.34.0
Your operating system & version: Debian 11

Hi all,

First of all, let me say how happy am I having found Tailscale. It is a real pleasure having this abstraction layer to focus on the work. Creating seamlessly “bridges” between all the remotes machines is incredible.

I am using Tailscale for some time now and there is still one issue I can’t figure out.

Connecting a new node to the tailscale net is easy and everything works fine, but if I try activating the --accept-routes parameter the remote machine is still reachable through tailscale IP but not the local IP.
Installing from machine A tailscale on machine B, without the parameter, registers machine B with a tailscale IP.
Activating the --accept-routes parameter breaks the access from machine A to machine B through local IP but not throught tailscale network. However, the reverse works I can ping B from A on the lan.

May I ask if someone has any idea how to make it work?

Thank you.

Kptn

Please search the forum; this issue has been reported a number of times and there is an open GitHub issue describing the issue and possible solutions (but unfortunately there aren’t any good ones yet).

The solution most of us use is to not use --accept-routes when the portable system is attached to the LAN, and use it when that system is not attached to the lan (e.g. while traveling).