Newbie can't connect with tailscale

Hi I am a newbie trying to use tailscale. I have it installed on POP OS 22.04. When I try to connect from my computer to my andorid phone I get a dns probe error. The same error appears when I try to reach my computer from my android phone. I have a surfshark vpn installed on both devices. If I turn surfshark off and try to connect I get the same error. I can connect to my pi-hole on my raspberry pi 3. Any ehlp would be appreciated

Try using the tailscale ip instead of DNS. As you use Linux learn that the problem is always DNS (or file permissions).

But wait, what do you have on your android phone that you’re trying to connec to? Can you connect from your phone to your PI?

That sounds like trouble. I think that if you want to use tailscale, you don’t want to use surfshark. They both do the same thing, so I think it would be hard or impossible to make them work together.

Oh. You tried that.

Thanks for the response. I will try to connect my phone from the pi. I want to be able to connect to my computer remotely from my phone or tablet to watch videos or hear music.