How to always start as an exit node?

This is probably more of a Linux question than Tailscale, but how can I always start as an exit node? tailscale up --advertise-exit-node works as expected but not persist after reboot. I’m running Ubuntu 20.04 LTS on a dedicated device and would always like Tailscale to run as an exit node. My knowledge of modern Linux service management is pretty basic and I didn’t see any mention of preferences in the CLI docs.

try adding --force-reauth. It will make you re-login, but wont change your IP or anything. This fixed it for me when I had some issues similar to yours.

tailscale up --advertise-exit-node --force-reauth

What fixed a similar issue for me was to run “sudo tailscale up --reset” to reset all flags to default, and then do “sudo tailscale up” with my desired flags. After that, things persisted OK after reboot.

I’ve had a few instances where --reset didnt work by itself and --force-reauth (or some combination of the two) finally fixed it.

This seems to have worked, thanks.