Settings on linux not persisting across reboots

Running Tailscale on linux. The first time I ran it, I used the below flags:

sudo tailscale up --advertise-exit-node --accept-dns=false

If I run “tailscale up” again with other flags (including --reset), I was expecting those settings to persist on reboot, but I’m finding that every time I reboot the machine, Tailscale is set back to the above flags.

Is this intended? How can I get new settings to persist across reboots?

Can you run tailscale bugreport and provide the bugreport string (either here or e-mail to

If you run tailscale up on its own, it should reuse the previously saved settings. If you use tailscale up specifying all of the flags used previously (or with -reset) it should save new settings that will be persisted across reboots. From your description, it appears you are likely following the correct steps already but the new settings are not being saved.

Is it possible that the filesystem with /var/lib/tailscale is read-only or that a startup script is running tailscale up with the original flags you set? Those are the only ideas I have off the top of my head; perhaps the logs will offer more insight into what’s happening.

Thanks for that, I tried running “sudo tailscale up” (no any additional flags at all) and now it seems to be working - after rebooting the machine, tailscale is up automatically with my desired flags (–advertise-exit-node, and --accept-dns=true)

Small update, I had this same exact issue on a second linux machine, but the fix I had to use there was:

  1. run “sudo tailscale up --reset” to reset all flags to default. The CLI returned “Success”.
  2. run “sudo tailscale up --advertise-exit-node” to re-advertise as exit node. No “–reset” was required here.

Now this setting does persist on reboot as desired.

Side note - there’s no easy way to tell whether “–accept-dns” is currently set to true or false on linux, without trying a “tailscale up” and seeing whether the CLI tells you you need the “–reset” flag to change whatever the current setting is. Would be handy to have this shown in the Tailscale login page, and I guess if the default is “true” then it’d make sense to just signal when it’s off.

Side note 2 - in the Tailscale login page, fully active exit nodes are shown in blue-highlighted text, but if there’s an issue (either it’s advertised but not enabled yet, or it was previously fully active but has since stopped being advertised), a little exclamation mark icon shows up next to “Exit Node” but the text is still highlighted blue, so it’s easy to miss that something’s up. Would be great if there was a colour change to more easily identify that something has changed.

For --accept-dns feature request has been created: How to find -accept-dns is enabled or not in Tailscale on Linux? · Issue #2130 · tailscale/tailscale · GitHub. Please subscribe to it for future updates.

Exitnode is having misconfigure; it should shows up in other colour highlight to recognize easily. · Issue #2131 · tailscale/tailscale · GitHub for Exitnode highlight feature.