Exit Node Always Used

Just setup my Tailscale. First setup with a machine in the cloud and laptop in my house worked great. I could ssh to cloud machine over 100 network and all my other traffic went over my ISP.

Then I configured the cloud machine as an exit node, following instructions. I only want to use the exit node when I am on the road in hotel or airport.

I tested starting tailscale on my laptop with the exit node parameters. All good. My public IP changed.

I then wanted to revert to just use it in normal mode without the exit node. I did tailscale down. And then tailscale up without the exit node parameters.

Problem is, all routing is through Tailscale. My public IP changes to match my cloud machine.

Is this intended? Is it possible to do what I am trying?

It remembers the settings the next time it is brought up. If you want to stop using the exit node and just use Tailscale to access other nodes on the tailnet, use:
tailscale up --exit-node=
(empty string for the exit node)