Exit node not working (probably not DNS)

Tailscale version 1.16.0
Your operating system & version Windows 10 and Linux PopOS 20.10


I have the following issue:

PopOS 20.10 (exit node) and WIndows 10 (client)

When I activate the exit node function on the Windows machine, the internet stops working. I can still ping the exit node via it’s 10.x IP but I cannot ping anything else (including the DNS servers). When I deactivate exit node, it starts working again.

I’ve configured IP forwarding on the exit node and tried disabling the Windows firewall.

Any clues? Thanks :))

Initially I thought it is a DNS issue, but actually Windows has set the DNS correctly (as specified in the Tailscale settings). However, it cannot ping those servers so I suppose they are useless. Suspecting some kind of routing issue.

And the exit machine itself can ping the servers. Tried both the server and some ISP provided servers.

Problem is not with the Windows machine per se, as same issue on my iPhone when I try to use the exit node.