Exit node issue

OK, that was incredibly easy to set up. I just have one small issue.

I set up tailscale on:

Synology NAS DSM7
iPhone 8 iOS 15.4.1
Windows 11 laptop

I have set the Synology to act as an exit node and also to route

The Synology will route traffic to the internal network from iphone and laptop

As a split tunnel, all works fine.

As a full tunnel, the internal network is still routed but the Synology won’t act as an exit node for the iPhone (Safari says no internet connection). Surprisingly it will act as an exit node for the laptop, even when the laptop is tethered to the phone!

If I connect the laptop directly to the same network the Synology is on and set that up as an exit node, the iPhone can use it correctly to get to the wider internet.

Am I missing something?

I’ve just installed Ubuntu as a VM on my NAS. Initially that didn’t work either, but after enabling IP forwarding it seems good (I got a prompt to do that when I installed Tailscale on my VPS yesterday fortunately, or I wouldn’t have had a clue).

So it’s just the native Synology NAS software that’s not working with my iPhone for exit. The iPhone can exit on other machines (when set up), including the VM hosted in Synology, and other machines can exit on the Synology.,


Have you enabled outbound connections on your synology?

  1. Using the Synology as an exit node works for my Windows 11 laptop, but not for my iPhone
  2. I tried the instructions anyway, but get the error “mknod: /dev/net/tun: File exists”

The permissions for /dev/net/tun are 600, not 666, so I changed them.

It still doesn’t work on my iPhone
It still does work on my laptop

sudo ping 100.x.x.x doesn’t work

I didn’t see an easy way to restart Tailscale.

I tried running sudo /var/packages/Tailscale/target/bin/tailscale configure-host but that just gives the useage text.

Rebooting the NAS puts the permissions of Tun back to 600

(The iphone can use a VM as an exit node)

I tried running sudo /var/packages/Tailscale/target/bin/tailscale configure-host but that just gives the useage text.

configure-host was added in the 1.22 release, which hasn’t made it into the package center. You’d need to load the package from https://pkgs.tailscale.com/stable/#spks