Cant connect to linux machine (Fortinet issue?)

I have a few machines on my network and I can access them via ssh and sftp without issue. Among them are my Raspberry Pi, a Win10 machine and my phone.
Today I installed Tailscale on my Linux Mint machine and did the setup according to the docs.
tailscale ip -r
produces the same ip as the one shown in the admin console for this machine. And the machine is shown as active in the admin console as well.
Furthermore, running:
tailscale status
seem to be listing all my machines with the correct IP’s aswell.

I can’t however connect to the machine in any way it seems. Tried ssh connecting and also adding it to SolidExplorer. But I get connection timed-out errors. Tried restarting the target machine and rechecking that tailscale was running, but still wont work.

Now the only difference I can find that might mess up connecting to this machine is the fact that Fortinet is installed on the target machine. And I seem to be forced to keep it installed as it’s the only way to connect to my school’s network for some reason which I need to do continuously for the next few days. So I cant unfortunately remove it to test if it’s the issue.

How do I first of all figure out if Fortinet is the problem?
And if so, how do I get around it? According to my school’s docs, Fortinet is the only way we can establish connection to their servers, so I do really need to keep it.