Missing tailscale0 interface on raspberry pi

I had to recently install everything on my rpi and after installing tailscale, I no longer see tailscale0 in my network interfaces. I think because of which I cannot ssh into my rpi (through tailscale connection) - says, connection timed out; nor can I access any of my apps (using the ports).

I was able to do these things before, but now I cannot connect to anything on my RPI (even though it shows up on my admin page as connected, no expiry, exit node.

  1. Is there a way to get that interface installed? I tried uninstalling tailscale and reinstalling it, but that didn’t work.

Here is my setup, if it helps (and if I miss out on something, please ask):
RPI 4 with latest os version (bullseye)
Docker + Portainer
Apps installed: Home Assistant, Webmin, OMV and others that I don’t think could interfere with network interfaces’ configuration.
Tailscale is updated to the latest version (as of date) - 1.18.2 on RPI and Windows. MagicDNS is set to disabled because it changes my /etc/resolv.conf and removes my original DNSes making the net inaccessible.

Thanks for all the help. Cheers to the tailscale team for an amazing product.


Are you using a stock Raspbian install? That could happen if there is no /dev/tun device to bind to.

check ls /dev/net/ and see if there’s a tun device there.

The other thing to try is to completely remove tailscale.
sudo apt remove tailscale --purge then sudo apt install tailscale and go through the login process again. That will reset your tailnet IP address though.

Yes, I am using stock Raspbian.

No, /dev/net/ did not have tun in it.

I removed and installed tailscale and it works now. But, can you tell me, why tun would go missing and if it does, how would one get it back without uninstalling/installing tailscale (or any other service)? This one is just for my curiosity even though my problem is solved.

Thanks for taking the time to respond and helping out Jay. Wish you wonderful day ahead.

Uninstalling/reinstalling tailscale should not have had an impact on whether there is a tun device. Presumably something else happened, perhaps installing a dependency when the tailscale package was reinstalled.

You are right about something else getting messed up, but I don’t know what.

When I reinstalled tailscale using the instructions on the website (for RPI), I also ran the command for the dependency, but it returned with “package already installed” message, so, I don’t think it was the dependency that was missing.

My only guess is that one of the other apps I installed, might have messed up the interfaces. Home assistant, these days, is messing up a lot on my RPI and it could be the culprit, but since I am no expert on networking, linux, containers or home assistant, it’s just a biased guess.

Nevertheless, I am glad I can ssh into my rpi or use the apps after re-install.

I would be happy to assist in identifying the root-cause of the problem, so if you want, I can share whatever you may need to figure it out. Just a caveat, you might need to instruct me on how to get that information.

Cheers DG. Have a beautiful day ahead.