Cannot access remote networks from Linux desktop PC

I have a number of working remote tailscale instances.
With a windows PC on the same network as my linux PC I can access the remote sites with no issues.
Windows I can ping, https, ssh etc into remote devices perfectly.
Worked really well when I was away last week on holiday.

I rebuilt my Linux PC today, Ubuntu 23.04, clean install.
Re installed tailscale, manually, registered with TailScale.
I cannot access the remote sites.
Previous to this on 22.04 I had the same problem.

Tailscle status gives me this info on my linux PC
100.108… paul-hp-compaq-elite-8300-sff paulhew69@ linux - REBUILT LINUX
100.77… chiff-unifi-pihole paulhew69@ linux idle, tx 1620 rx 2124 - Home access
100.66.---- duns-vpn paulhew69@ linux -
100.82… pmfh-tscale-chrtrs-1 paulhew69@ linux -

Chiff-unifi-pihole is on the same network as my linux machine.
duns and the other network I cannot access from Linux

Checking windows PC sitting next to me shows that duns and pmfh… are active.
And I can log into https pages with no issues.
I just installed tailscale, authenticated the pc and it worked.

What am I missing please on my Linux machine.
I did check the documentation, to make sure I ran all of the commands.