Windows 10 - Taildrop receive file

I am unable to receive files on my Windows 10 machine using taildrop. I have tried sending files from iOS and Linux with no success. I can send files from Windows 10 to the other devices, and it works. Could it be a Windows firewall issue?

I don’t think it could be an issue with the Windows firewall: packets are encrypted up to the Tailscale service, so the firewall doesn’t see them, and after decryption the packets involved in Taildrop get consumed before the firewall gets a chance to see them.

Are you able to tailscale ping the system, or access other services on it?

Another thing to check: when you send a file to your Windows 10 device using Taildrop, does it report an error, or does it say it was successful and then the files don’t appear on the desktop?

I received no notification on the Windows 10 PC just the error above that shows that it failed on the device trying to send it from.

If I ping tailscale IP from raspberry pi to Windows 10 I received nothing. If I do it the other way around I receive packets.

Please send us an email with the issue details on; we will set up a call for troubleshooting.

I have installed Tailscale in one of my other Windows machines and I was able to use Taildrop without any issue sending a file from iOS to Windows. So it looks like whatever issue I am having is just with the one machine.

So a little bit more testing I installing it on a another laptop running Windows. Came up with the same issue where I was not able to receive a picture I sent from iOS. I’m running multiple guest networks and I just switched to a different guest login on the laptop and then it was working. The desktop I was having issues with is wired but does have Wi-Fi. I switched it to the Wi-Fi guest network and it worked. Interesting! Switched it back to the wired network and now it works. Sending files back and forth between all the connections work.

I’m glad it is working.

Despite what it looks like, Taildrop is not specific to Wi-Fi. I don’t know why it suddenly started working on a Wi-Fi network, but it should work whenever you are connected to Tailscale via any network.

1 Like

Yes I understand, but for whatever reason it started working. I do hate not knowing why but for now I’m happy that it is working.