Bug in taildrop to windows

There is a bug in the taildrop windows client when the windows machine has onedrive installed. In this instance, the desktop folder is not in \users<name>\Desktop but instead it’s in \users<name>\Onedrive\Desktop. Taildrop should be using the SHGetKnownFolderPath API with FOLDERID_Desktop see here for more deatils: SHGetKnownFolderPath function (shlobj_core.h) - Win32 apps | Microsoft Docs

Great, thank you. Filed as Windows Taildrop should use SHGetKnownFolderPath for destination folder · Issue #2112 · tailscale/tailscale · GitHub to get it fixed.

For those coming across this later, an unstable 1.9.164 build went out last night containing this code change and will be in the 1.10 release.

Send files to other devices by right-clicking on the files and choosing “Send with Tailscale…” from the menu in Windows 10, But in my mouse right-clicking list with file, the “Send with Tailscale…” function is missing.
Client version is 1.8.7

So you don’t get this, when right-clicking on a file?
Are there any apps listed?

Screen Shot 2021-06-13 at 6.36.27 AM

Picking up this thread, as I’ve been trying to figure out why “Send with Tailscale” isn’t appearing among my available options when right-clicking on a file.

Other apps show up, but Tailscale isn’t among them.


If you’re running Windows 11, it is hidden under “Show More Options”


Thanks for the quick reply!

I’m in windows 11, and as I was trying to grab a screenshot demonstrating the issue, I learned what I was getting wrong. “Send with Tailscale” doesn’t appear when a folder is selected, but does for individual files.

1 Like