Where is TAILSCALE_USE_WIP_CODE?

I downloaded Tailscale from the App Store and I’m on a MacBook Air with Monterey 12.5

The docs say that this installation already comes with the CLI and to enable the computer as an ssh server (not client) to just run tailscale up --ssh.

% tailscale up --ssh
2022/10/09 13:03:34 The Tailscale SSH server is disabled on macOS tailscaled by default. To try, set env TAILSCALE_USE_WIP_CODE=1

Where is that variable located? In a config file for the app? Or as a general environmental variable?

I added export TAILSCALE_USE_WIP_CODE=1 to .zshrc and did source .zshrc and made sure the environmental variable had been set and was working. But the command returns the same output.

  • Is there somewhere in the application I should set this variable?

  • The documentation actually says “This is only supported on Linux devices”. Is that really true?

Would compiling the source code or using the “standalone” version of the download fix this?

SSHing conveniently into my Mac was my reason for using Tailscale so I’d love to know if this feature is supported.

I also quit Tailscale and moved it to the bin, then downloaded the standalone version, dragged it into applications and launched it. It never prompts me to sign in, it just says “VPN loading” indefinitely. I then quit and now I can’t even open it. Did I need to uninstall the App Store version more extensively before installing the standalone version?

Thanks very much

I am using the CLI version of tailscale on macos and also can’t figure out the TAILSCALE_USE_WIP=1 setting. Poking around the go code, it seems to be a shell environment variable but either I am misunderstanding how to use it or there may be some bug in the program logic. Here is a fragment from my shell that appears to show that it is getting properly passed into tailscale but not interpreted correctly.

% TAILSCALE_USE_WIP_CODE=0 tailscale up --ssh
The Tailscale SSH server is disabled on macOS tailscaled by default. To try, set env TAILSCALE_USE_WIP_CODE=1
% TAILSCALE_USE_WIP_CODE=1 tailscale up --ssh
The Tailscale SSH server is disabled on macOS tailscaled by default. To try, set env TAILSCALE_USE_WIP_CODE=1
% TAILSCALE_USE_WIP_CODE=X tailscale up --ssh
2022/10/16 21:14:56 invalid boolean environment variable TAILSCALE_USE_WIP_CODE value “X”

I don’t have a specific solution for your other problem of changing macos application types but I recommend using a program like AppCleaner when removing applications on macos so that associated files located elsewhere are also removed.

Also confused here! Anybody got a solution?

I think there is an issue with the app store version. Try brew install tailscale then locate and start the daemon with sudo TAILSCALE_USE_WIP_CODE=1 /opt/homebrew/opt/tailscale/bin/tailscaled. After starting the daemon in a new terminal window tailscale up -ssh should work.