Tailscale seems to be blocking Pi from updating

When I run ‘sudo apt-get update && sudo apt-get upgrade -y’ on Rpi 4 running 32bit bullseye, with tailscale running it is unable to retrieve the data as a ‘connection refused’ error is reported.

Any help would be appreciated. Thanks.

Can you run tailscale bugreport immediately after trying your apt update and send us back the code?

yes please see below…
pi@MyRaspiServer:~ $ tailscale bugreport

I don’t see anything blocking.

Could you try to run traceroute tailscale.com from the pi with tailscale down.

yeah sure, please see below…

1 _gateway ( 0.403 ms 0.259 ms 0.219 ms
2 ( 11.190 ms 10.742 ms 15.559 ms
3 hudd-core-2a-xe-130-0.network.virginmedia.net ( 15.771 ms 16.489 ms 16.010 ms
4 * * *
5 tcma-ic-2-ae9-0.network.virginmedia.net ( 16.885 ms 16.323 ms 15.944 ms
6 ( 56.982 ms 25.944 ms 25.985 ms
7 ( 21.417 ms 30.386 ms 30.624 ms
8 ( 24.619 ms 23.799 ms 24.630 ms

I was thinking that there might be a CGNAT colliding with the tailscale ip space, but that is not the case.

I’m going to need to dig further, this is an interesting case.

ok, just let me know the next step to take. BTW I’m a relative noob so please bide with me.

Just confirming, with tailscale down, you are able to run your apt upgrade?

Could you show the results of ip route show table all with tailscale up and with it down?

Hi Jay

Everytime I try and reply I keeping getting ‘Sorry, new users can only put 2 links in a post.’ Is there a limit to the amount of text?

I’ve even tried uploading a text file but it won’t allow me.

Possibly. Could you email it to support@tailscale.com?

yes np… give me 5 mins… I’ve sent it now

Hi Jay I have enabled Magic DNS but still having the same issue

What I think you should try:

Under Tailscale DNS settings
Set a public DNS server as the global override.

This is my setting.