Tailscale on Asus AX86U


Has anybody sucessfully installed Tailscale via Entware? I’ve installed it, sucessfully logged into my account and it has an assigned IP when I run tailscale ip -4. I can see the AX86U listed on the Tailscale admin panel and it shows as connected but there is no connectivity, I can’t ping the AX86U Tailscale IP from any of my peers and I can’t ping any peers from the AX86U or any clients connected to the AX86U. I am also running Martineau’s WG manager, Skynet and Diversion.

I’ve Googled and found a few forum posts about setting it up but I’m not 100% sure on what commands I should be running, if I run tailscaled --state=tailscaled.state I get the following info but it just hangs and doesn’t complete then I have to exit out.

RT-AX86U-CC60:/tmp/home/root# tailscaled --state=tailscaled.state
logtail started
Program starting: v1.28.0-dev20220727-t4a3ee6dac, Go 1.18.4: string{“tailscaled”, “–state=tailscaled.state”}
LogID: 50ef4069116a3806e1a5503015ab2f864ebe6ab77aa44fd436d8959f4a2ea7e7
logpolicy: using UserCacheDir, “/root/.cache/Tailscale”
wgengine.NewUserspaceEngine(tun “tailscale0”) …
setting link attributes: setsockopt: protocol not available
router: disabling tunneled IPv6 due to system IPv6 config: disable_ipv6 is set
dns: [rc=unknown ret=direct]
dns: using *dns.directManager
link state: interfaces.State{defaultRoute=eth0 ifs={br0:[] eth0:[xxx.xxx.xxx.xxx/24] tun21:[] wg11:[] wg21:[]} v4=true v6=false}
magicsock: disco key = d:290b521bd0a18b42
Creating WireGuard device…
Bringing WireGuard device up…
external route: up
Bringing router up…
Clearing router settings…
Starting link monitor…
Engine created.
using backend prefs; created empty state for “_daemon”: Prefs{ra=true dns=true want=false routes= nf=on Persist=nil}
Backend: logs: be:50ef4069116a3806e1a5503015ab2f864ebe6ab77aa44fd436d8959f4a2ea7e7 fe:
Switching ipn state NoState → NeedsLogin (WantRunning=false, nm=false)
health(“overall”): error: state=NeedsLogin, wantRunning=false
wgengine: Reconfig: configuring userspace WireGuard config (with 0/0 peers)
wgengine: Reconfig: configuring router
wgengine: Reconfig: configuring DNS
dns: Set: {DefaultResolvers: Routes:{} SearchDomains: Hosts:0}
dns: Resolvercfg: {Routes:{} Hosts:0 LocalDomains:}
dns: OScfg: {Nameservers: SearchDomains: MatchDomains:}

Running /opt/etc/init.d/S06tailscaled start and that seems to be sucessful:

RT-AX86U-CC60:/tmp/home/root# /opt/etc/init.d/S06tailscaled start
Starting tailscaled… done.

Running tailscale up also seems to be sucessful.