Switch from cellular to Wifi Tailscale still uses cellular to exchange data

I started tailscale outside where there was no wifi connection, then I went office and my phone connected to wifi, from what tcpdump shows is that the VPN connection still use celluar to exchange data:

100.122.102.75 debian-router darren.hoo@ linux -
100.101.24.76 darren-iphone darren.hoo@ iOS active; direct [2408:8406:1900:a0d0:2532:6f94:fdd:ac5]:41641, tx 9299496 rx 559752

tcpdump from 100.122.102.75 debian (home router)

09:21:33.220710 IP6 2408:8206:1903:636f:2f1:f3ff:fe17:4d88.41641 > 2408:8406:1900:a0d0:2532:6f94:fdd:ac5.41641: UDP, length 96
09:21:33.344998 IP6 2408:8206:1903:636f:2f1:f3ff:fe17:4d88.41641 > 2408:8406:1900:a0d0:2532:6f94:fdd:ac5.41641: UDP, length 272
09:21:34.030259 IP6 2408:8206:1903:636f:2f1:f3ff:fe17:4d88.41641 > 2408:8406:1900:a0d0:2532:6f94:fdd:ac5.41641: UDP, length 92
09:21:34.051270 IP6 2408:8406:1900:a0d0:2532:6f94:fdd:ac5.41641 > 2408:8206:1903:636f:2f1:f3ff:fe17:4d88.41641: UDP, length 110

After I manually switch off and on tailscale, it uses the wifi connection:

100.101.24.76 darren-iphone darren.hoo@ iOS active; direct 192.168.10.167:6409, tx 10733480 rx 3713496

So is it work intended?

This could very well explain the issues we are seeing here: Excessive data usage - #26 by Lostboy

I suspect that this is actually an issue that I have also seen, but I haven’t been able to confirm it.

1 Like

This should be fixed by wgengine/tsdns: MagicDNS fwdConn never appears to rebind on link change · Issue #1480 · tailscale/tailscale · GitHub and will be included in the upcoming 1.6.0 release next week.

Tried tailscale 1.6 on iOS (with testflight) and linux (tailscale 1.6), the problem still exists.

iOS: 100.101.24.76
Linux: 100.122.102.75

the steps

  1. Turn off tailscale using toggle button on the UI and swiped the UI off (ie kill it)
  2. Turn off Wifi and use Cellular 4G
  3. Launch tailscale and switch it on
  4. Ping from linux to iPhone to make sure tailscale is up through Cellular.
  5. Keep ping from linux and tcpdump to watch the data flow.
  6. Turn on Wifi wait for a while, tcpdump shows that data still go through Cellular.
  7. Turn off and on tailscale using toggle button on the UI, this time the data still go through Cellular!
  8. Turn off Cellular from iOS settings, this time the data exchange over wifi now.

here’s the problems:

  1. Switch from Cellular to Wifi, tailscale still uses cellular.
  2. Just Turn off and on tailscale from the UI (without turning off cellular data) won’t work, this really surprises me.

EDIT: the version on iOS is actually1.5.215 (testflight) not 1.6, will try again after release

1 Like

I will join the TestFlight Beta track and test this out as well.

I have been trialling the new 1.6 release.

Two days ago while I was on wifi at the office all day I managed to use 6.5GB of cellular data.

Unfortunately I don’t have more detail than that, other than my phone was connected to WiFi for 99% of the day and I didn’t watch any videos on mobile data during that time.

I can try and debug further moving forward I am just short on time at the moment