Safari cannot open the page because the server stopped responding

I installed Tailscale on my iPhone and laptop which runs on windows. When I try to connect to my laptop from my iPhone I get the following message ”Safari cannot open the page because the server stopped responding“. This is my first time installing Tailscale and attempting to use it. I have not yet been able to get it to work due to receiving that message. I am not whatsoever tech savvy so your help would be appreciated in the “Tailscale for dummies” language.

I get the same error message intermittently. Here’s what I’ve been able to determine so far:

I have a server, iphone, and laptop on my tailnet. Everything is also on the same local network. The server is serving a web application on both tailscale and LAN interfaces.

Sometimes when visiting the web app from my iphone, the page load hangs and eventually I get Safari cannot open the page because the server stopped responding. This happens maybe every 10 minutes, if I’m checking regularly.

I have only seen this on my iphone, only using the tailscale IP.
Using the IP assigned by my router never hangs, on phone or laptop.
Using the tailscale IP from my laptop never hangs.

It happens often enough that I will:

  • notice the page load stalling on my phone
  • switch to another tab in safari with the 192... IP
  • reload that page successfully
  • switch back to tailscale IP tab, find the page is still trying (unsuccessfully) to load.

I have also confirmed the laptop successfully loads the page via tailscale IP while this is happening.

As far as I can tell my phone is using a Direct connection.
I have tried with magicDNS both on and off. I have no other VPNs installed on the iphone.

Does anyone have an idea what’s going on? Is there anything else I can try to debug?

I still encounter this on and off. Any idea from Tailscale’s side what might be the cause?