Rsync between Synologys over Tailscale

Tailscale version: 1.30.2-300027
Your operating system & version: DSM 7.1.1-42962 Update 2

This may not be anything you can help me with but I figured I couldn’t be fired for asking! It is specific to Synology AND rsync AND Tailscale.

I set up Tailscale on my two Synologys while they were in my house, and set up rsync to back up one to the other. I moved one Synology to a friend’s house and rsync is failing. Tailscale is definitely running on both, as I can log into both with their MagicDNS (how awesome is MagicDNS???)

The problem is with rsync on the Synology. When I define the destination for a specific rsync task, it has a field for the Server name or IP address. It scanned my network when the second machine was at home, and found its MagicDNS name but it assigned it to its local IP, not its Tailscale IP.

I can’t seem to override this field because as soon as I click on it, it scans the network again and doesn’t find any servers set up as destination rsync servers.

I’ve tried creating a new rsync task and it does the same thing - scans just the local network, not the Tailscale network, looking for rsync destinations.

If anyone has an idea how to override this field so I can enter the Tailscale IP, or if there’s a flaw in my thinking and there’s another solution, I’m all ears!

i assume you use hyper backup for this?

I just checked with mine. In hyperbackup, create a new backup-job. Select “rsync” (not “remote-nas-device”). Than under servertype select “rsync compatible server”. This lets you manually specify the IP-Adress.

Edit: also works with “Synology rsync server”

Dagnabbit - I turned on every notification I could find but didn’t get notified that you’d replied @jonas108 !

I’m not using HyperBackup but I might have to switch to it. I’m using the native built-in rsync that you can find in File Services. It worked grand when they were on the same “normal” local network but it doesn’t seem to know that the Synologys are on a Tailscale network together.

I probably should throw in the towel and switch to HyperBackup but my goal was to have the remote Synology to mirror the files on the local one just for ease of looking at the files.

I just spent more time researching your suggestion - I dismissed it out of hand without understanding that Hyper Backup does more than I thought. My apologies.

I’m stuck in the same way I was with the File Services method of getting to rsync. It says no response from the destination server when I use the Tailscale IP. I’ve confirmed I can ping the destination on that IP, and I’ve confirmed that rsync is enabled on the port I’m trying to use. I can access both Synologys using their Tailscale IPs.

Can you think of what I can be missing?



Just to Double Check, did you enable the outgoing Connections in both NAS?


I knew nothing of this. I just enabled outbound on the source (local) Synology, changed the destination IP to the Tailscale of the remote and BOOM it worked. I wish you could see the size of the smile on my face right now. I have been fighting this for 2 months.

In other news, a lovely gentleman in the Synology forums suggested what I think is the same script, except he set it up manually. I can’t wait to tell him that he was also right in the solution but help him do it more easily too.

Again, my heartfelt thanks. You rock!

Allison Sheridan
Podfeet Podcasts at
Technology geek podcasts with an EVER so slight Apple bias!

1 Like

Thanks for your reply,

glad i could help!

I wrote up my trials and tribulations and gave you credit for my success!

I FINALLY succeeded at doing Synology Offsite Backup Using rsync Over Tailscale Synology Offsite Backup Using rsync Over Tailscale - Podfeet Podcasts

1 Like