Problem with specifying port in tailscale DNS

I’m running my DNS on port 5353

And I’m not able to specify that port in the tailscale DNS settings

Earlier I was able to specify a different port other than 53 for my DNS and, it worked perfectly but, now it is showing an error.