MacOS client and Subnet Routing


My goal is to have a remote MacOS (iMac 12.3.1) computer expose a subnet client, so I may manage LAN devices from afar.

I’ve tried installing the GUI version of tailscale. When I try the command

/Applications/ sudo tailscale up --advertise-routes=192.168.x.x/24

I get the USAGE response:

tailscale [flags] [command flags]
For help on subcommands, add --help after: “tailscale status --help”.
This CLI is still under active development. Commands and flags will
change in the future.
up Connect to Tailscale, logging in if needed
down Disconnect from Tailscale
logout Disconnect from Tailscale and expire current node key
netcheck Print an analysis of local network conditions
ip Show Tailscale IP addresses
status Show state of tailscaled and its connections
ping Ping a host at the Tailscale layer, see how it routed
nc Connect to a port on a host, connected to stdin/stdout
ssh SSH to a Tailscale machine
version Print Tailscale version
web Run a web server for controlling Tailscale
file Send or receive files
bugreport Print a shareable identifier to help diagnose issues
cert get TLS certs
–socket string
path to tailscaled’s unix socket (default /var/run/tailscaled.socket)

I turn the GUI off.
I tried to install via the CLI method (while the GUI method was still installed):

(Tailscaled on macOS · tailscale/tailscale Wiki · GitHub)

I installed Go
I installed the Daemon and confirmed the binaries exist in the folders

When I try tailscale up I get the return -bash: tailscale: command not found

Can anyone help push me in the right direction?

Most likely the tailscale binary is still in the $HOME/go/bin/ folder. You can either run the command as “$HOME/go/bin/tailscale up” or simply copy the tailscale binary into /usr/local/bin/ and then “tailscale up” should work.

1 Like

Thank you - this solved the issue!