Can't get a Windows Server 2019 Install to Stay Running after a Reboot

I’m just playing around with a Windows 2019 server install under Proxmox. Really just for learning so not production or anything, but I can’t keep Tailscale running after a reboot.

Initially, I just signed in as administrator, downloaded Tailscale, signed in, and I could RDP in no problem. After a reboot, Tailscale would only run if I was logged in (I dont remember if this worked after a reboot or not?), so I enabled “Run Unattended” with the intention that it lets me RDP in whether my user is logged in or not.

Now, after every reboot, Tailscale is not running. If I log in via Spice, the Tailscale icon pops up greyed out. Clicking on it gives me an error like this (this is the latest one):

Tailscale Error
Tailscale service stopped.

Version 1.20.4 (t8c6cb1cea-g2accf24a5)

LogID: a381dc58267fd21b743e0a29bf70b1a1bff82c3569cba212b26b684e7af14bdf
(Ctrl-C to copy this text)


Restarting the Tailscaled service fixes the issue, but it comes back every reboot.

I have tried uninstalling, removing all files from ProgramData and user/local folders, rebooting, creating a new user (thinking maybe its an admin issue), reinstalling, resigning back in, and I get the same issue. I even tried the same, but logging and tagging via CLI. No change.

Any ideas what would be causing this? I cant find any logs saying why it stopped.

Never did figure this out. Did a full reinstall and it worked. Something was messed up on the initial install of Windows Server.

1 Like