Can't access Truenas Scale GUI after Tailscale config change

I have been running the official Tailscale app on Truenas Scale successfully.

I was recently trying some configuration changes to enable replication over the Tailscale VPN (which requires host access to the VPN). Based on some posts I saw online, I disabled userspace for the container and enabled it as an exit node. This was not successful, so I turned off the exit node. After that change, I am unable to access the Truenas GUI, or any of the apps through their normal ports.

I know that the Truenas server is still running, as I am receiving email notifications (Google SMTP) from it for various events. However, inbound connections do not seem to be working.

I have tried stopping the tailscale app from the CLI using approach referenced in this post:

The command was: k3s kubectl -n ix-tailscale scale --replicas=0 deploy tailscale
Output was: deployment.apps/tailscale scaled

I tried accessing the Truenas GUI immediately after this, and also after rebooting the system. In both cases the GUI URL times out.

I’ve tried posting on the Truenas forums but have not received any responses. :frowning:

I would greatly appreciate if anyone could assist with how to recover from this.