Unable to start Tailscale on Ubuntu 20.04

Tailscale version - 1.36.1

Your operating system & version - Ubuntu 20.04 Focal


On fresh ubuntu install on proxmox LXC, I ran the script

curl -fsSL https://tailscale.com/install.sh | sh

to install Tailscale. Installation itself looks fine without any error. But when I tried to run Tailscale up, I got the following error:

root@ubuntu:~# tailscale up
failed to connect to local tailscaled; it doesn’t appear to be running (sudo systemctl start tailscaled ?)

Tried sudo systemctl start tailscaled command, but running tailscaled again shows the same error. Help?

1 Like

I have this problem on Raspberry Pi too. I find a reboot makes the problem disapear.

I have been having the very same issue and rebooting does nothing to resolve it. I have been asking around and stumbled upon this but really do not know what to do with it:

Tailscale client on Linux needs access to /dev/net/tun to be able to create a tun network device. f you are running in a container, you might need to explicitly pass /dev/net/tun to the container, or use userspace networking mode.

And this:

There is a difference in using a VM, LXC or privileged LXC.
Looks like you try to run int within an unprivileged LXC container.
Easiest way would be, to run it within a real VM instead an LXC container or use a privileges LXC with manual allowed TUN access.