Ubuntu network manager dns entry confusion

Local Ubuntu 22.04 runing tailscale
remote tailscale on raspberry pi
remote pihole on same raspberry pi

Ubuntu network manager requires the entry of a dns server. If I only input the dns server ip address of the remote raspberry pi running pihole which is in the tailscale network, a connection is never established unless I preceed that a publically available dns server like or So you see the dns entry for ubuntu network manager looks like: 1,1.1.1,

In a way I see how that makes sense: my local ubuntu computer needs to first get access to the public internet before it can make a connection to the remote internal network using tailscale. But leaving the public ip address of a or in the ubuntu network manager makes my local ubuntu machine use the first public ip address of or, not the ip address of the remote tailscaled pihole.

Running cat /etc/resolv.conf always show as the nameserver despite my inputing the remote pihole internal tailscale address.

So confusion abounds. . . .

Disabled magicdns and that did the trick. Don’t know why but it now enrolls itself easily into the tailscale network without applying a non-tailscale dns entry before the tailscale entry in Ubuntu 22.04 network manager.