Tailscale 1.20.1 on iOS: no DNS when using exit nodes

Since upgrading to 1.20.1, I’m not able to get any sites to load at all when connected to an exit node. All devices in my tailnet are updated to 1.20.1.

  1. On iOS, connect to an exit node.
  2. Try to access any website in Safari - nothing loads.
  3. Disconnect from the exit node - things load again.
1 Like

Trying the same thing on macOS:

  1. Connect to an exit node
  2. Try to access any site - nothing loads.
  3. Go to Preferences and disable “Use Tailscale DNS Settings” - now sites will load


it looks very much like the issue I am seing on Android like others as described in this Github issue: Tailscale on Android breaks Internet Access when Exit Node to a Linux system is turned on · Issue #3738 · tailscale/tailscale · GitHub

For what it is worth, I am not experiencing this under these conditions:

  1. iPhone is on 1.20.1
  2. exit node is on 1.18.2

Everything is working for me as expected. Could you revert to 1.18.2 on your exit node to see if that resolves the issue until it is fixed by TS?

1 Like

This is recent and totally on point for OP: exit-node-allow-lan-access not working on Linux in 1.20.1 · Issue #3750 · tailscale/tailscale · GitHub

1 Like

Thank you! This solved my problem with DNS.

Yesterday, I decided to update all my clients

Linux (exit-node): 1.18.2 → 1.20.2
IOS: ??? → 1.20.1
Android: ??? → 1.20.0
MacOS: ??? → 1.20.1

??? - means I don’t know what previous version was

After your comment I fixed my issue with

On Linux (exit-node)

sudo apt-get install tailscale=1.18.2

My situation almost identical to @a_edakin. Same solution—downgrading Linux tailscale to 1.18.2.

1 Like

glad to hear it worked, @a_edakin & @blaboykp

Subscribe to / keep an eye on the GitHub issue I posted above – the guys know it is broken in the latest version; i’m hopeful they’ll patch soon

1.20.4 in Linux working. Just updated my Linux box to 1.20.4 and it is working as an exit node. Thanks to the devs for getting it up again!