Reactivating tailscale on server

Hello world. Hope everyone is having a good day.
Just toke over the IT needs for a non-profit. The tailscale temporary keys expired for their machines, so we ended up disabling the key expiry. One of the machines (server) tailscale is on is still being seen as “last seen” a few weeks ago, so Tailscale can’t see it though we can access and log into the server ourselves (remotely as well). The tailscale network was working before the expiry per users.
We have tried logging in/out of the machine, restarted the tailscale plugin, we also tried a few Linux commands. Not to familiar with Linux to be honest, but imagine I will be soon.
We keep getting this error when trying a few Linux commands when trying to reauthenticate “tailscale: command not found”; we were running the “tailscale up --force-reauth” command, and a few derivatives of it as well. If someone wants to let me know what I am missing/getting wrong or if I need to do additional steps, let me know.
Thank you.