Linux no name server resolution

i am using tailscale version 1.4.5.
when rebooting opensuse tumbleweed i get no name server resolution, hence cannot connect to the internet. after reboot, if i do netconfig update -f i can then connect to the internet. using dhcp via att router. i also a similar problem on debian testing. restarting networking.service seems to fix it. on the debian i am using a static ip via the att router. all worked fine until I enabled ‘magic dns’ i have since disabled 'magic dns and the problem still happens. prior to 'magic dns all worked perfectly. any ideas ?

resolv.tailscale.conf
nameserver 192.168.1.254 – att router
nameserver 68.94.156.1 – public att dns
nameserver 68.94.157.1 – public att dns

It sounds like you’re running into trouble with the way we configure DNS. We have a plan to improve this (which is why MagicDNS is still in beta).

Most likely if you disable MagicDNS and remove the DNS IP Address setting (which you had to add before enabling MagicDNS), this will make the problem go away for now. Sorry for the inconvenience.

1 Like

thanks, i disabled 'magic dns and removed nameservers. all is back to normal once again. thanks!