Access EXSi server using VMWare Fusion or web interface

At home, I use an ESXi server to run various machines.

I’d like to use a Pi to enable access when I’m away. I’ve gone through the Subnet Router process a number of times now and am still unable to connect.

There are very limited options when configuring the ESXi server, save for setting a static IP from my home router, and clearly, TS installed can’t be installed on the hypervisor…am I missing something very obvious?

Thanks in advance for any help.

What specifically hasn’t worked with the subnet routing? It should work so I think you’ll need to give some more details to get more help.
ESX is linux based, so you almost certainly could get Tailscale working directly. I’ve not done it on any of mine however since it doesn’t seem worth the risk, even for unsupported hosts.
I’d add a small linux machine as a VM and use that to do subnet routing rather than adding another machine into the mix, even if it is only a Pi.

I would agree. I have done the same thing. ie create a Ubuntu server VM running tailscale directly on the server rather than using a separate Pi.
So far it’s worked very well including setting up a subnet by following the tailscale instructions.

I am interested in what you mention about running tailscale directly on ESXi?


Not really a lot more I can add - ESX is a Linux system so you should be able to download a precompiled linux binary and get it working or compile it from source. I’ve not done it, and with subnet routing working well it’s certainly not something I’d recommend anyone try.
It’s one of those things like running Doom on a pregnancy test - an interesting experiment but not worth the risk of birthing the spawn of satan.

Thanks, I agree :slight_smile: Not worth risking on ESXi… especially if one is running multiple critical VM’s…