MagicDNS over 4G doesn't work

Hi, I started using MagicDNS just now and noticed that all is fine and transparent (on my Android phone) if I’m connected via WiFi. If I switch Wifi off and rely on 4G than my phone stops being able to resolve domains try to go to. Switching off tailscale (or just MagicDNS) solves the problem.

BTW, I’m using MagicDNS with 1.1.1.1 and 8.8.8.8 DNS servers.

Please enable overrideDNS and share your observations.

I am having the same issue on Telstra in Australia. Wifi works fine, can ping internal dns names, external and tailnet. However, on 4g no DNS works without selecting Override DNS.

This is not practical for me to turn on however as at work and home I need access to internal DNS services (and on sites that I may visit with corporate networks).

Anyone else experiencing this?

I am also experiencing this problem on 4G. I have MagicDNS on, and DNS over 4G does not work on my Android device unless override DNS is turned on.

Is your telco using ipv6 for your cellular connection?

I’m also experiencing dns issues over 4g! On Telenor in Norway.
Unsure if provider is using ipv6; any idea how I can find out?

This is pretty widespread. Colleagues in my office have the same thing (but they don’t need to use Tailscale on mobile like I do). I really want to use magicDNS, can anyone from the Tailscale advise here?

To find your ip, turn off wifi and google search “what’s my IP”. If you don’t get a traditional public IP xxx.xxx.xxx.xxx. IPv6 is something more like xxxx.xxxx.xxxx.xxxx.xxxx.xxxx.xxxx.xxxx

Keen to see how it goes.