Installation on RTU running Yocto

Hi All,
I’m new to tailscale and successfully got it running on RPI3 & Windows after in 3minutes, nice and easy :slight_smile: After this I am trying to get it to work on a embedded device this runs a build of Yocto with an ARM processor to do this I did the following:
-Transferred the tailscale_1.14.0_arm.tgz file to the device

pscp -P 22 tailscale_1.14.0_arm.tgz root@

-Extracted the file

tar xvf tailscale_1.14.0_arm.tgz

-Navigated to the extracted directory and executed tailscale using:

./tailscaled --state=tailscaled.state

This seems to look like its successfully starting but then it gets hung up can any provide some feedback on what is the reason for this not progressing, I don’t have a etc/networkd file or IPV6 is this causing it?

tailscaled needs to be left running in the background. The output looks normal, it says it is in the NeedsLogin state.

You run tailscale up in a separate shell to tell it to authenticate. tailscale up will print a URL that you need to visit in the browser to log in, and then tailscaled will move to the Running state and be active.

Thanks DGentry, I ran tailscale up in a separate shell and used tailscale up as you suggested this worked but it never provided me with a URL it instead sat there and did nothing in the control shell in the program shell it is sitting there waiting to receive valid certificate (see image below).

Following this I generated a key following the instruction at Auth keys · Tailscale but this also continued to fail to authenticate with the same error as above. Any further guidance would be greatly appreciated - Thanks

“certificate expired current time 2021-08-12 is before 2021-08-23”

The Yocto system thinks today’s date is August 12, therefore it is rejecting the coordination server’s SSL certificate because it was created August 23. SSL requires that the system time be, not exact, but plausibly close to correct.

Setting the date and time using the date command would likely be sufficient.
To fix it for good I’d recommend looking at how to set up NTP for Yocto.

Thanks DGentry, pointing the Embedded device to the NTP server fixed the issue, silly mistake to stop reading the error message at the timestamp… I don’t have the original recipe for the proprietary build on my embedded device but did find the following link with a Yocto bitbake recipe which might help others wanting to build tailscale into their Yocto system Re: [yocto] Yocto recipe for Tailscale #yocto #golang