How to enable subnet routing in Arch Linux?

I’m using Arch Linux and I want to setup subnet routing as defined here: Subnet routers and traffic relay nodes · Tailscale

I followed the steps from the above link, and used the IPs specified there, namely,

and also set the ACL defined there:

  "groups": {
    "group:dev": [""]
  "acls": [
    // Users in group:dev and devices in subnets and
    // can access devices in subnets and
    { "action": "accept",
      "src": ["group:dev","", ""],
      "dst": ["*", "*"]

Currently, my iptables rules look like this:

[audiolinux@audiolinux2 Desktop]$ sudo iptables -S
-N ts-forward
-N ts-input
-A INPUT -j ts-input
-A FORWARD -j ts-forward
-A ts-forward -i tailscale0 -j MARK --set-xmark 0x40000/0xff0000
-A ts-forward -m mark --mark 0x40000/0xff0000 -j ACCEPT
-A ts-forward -s -o tailscale0 -j DROP
-A ts-forward -o tailscale0 -j ACCEPT
-A ts-input -s -i lo -j ACCEPT
-A ts-input -s ! -i tailscale0 -j RETURN
-A ts-input -s ! -i tailscale0 -j DROP

But, the problem is from my other machine (MacOS), I cannot ping my Arch Linux machine. I get the following:

myuser@mymachine ~ $ ping
PING ( 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1

I also cannot ping from Arch Linux my MacOS machine. I tried to toggle on and off in MacOS the settings like “Use Tailscale DNS settings” and “Use Tailscale subnets”, but nothing helped. Any ideas what the issue might be?