Unable to start tailscaled service on debian 11 container

Tailscale version 1.22.0
Your operating system & version Debian bullseye 11

Hello sir, could you guide me how to start tailscaled.service. i got an error message like this :
failed to connect to local tailscaled; it doesn’t appear to be running (sudo systemctl start tailscaled ?)

And when i try to run this command sudo systemctl start tailscaled. I got another different error :
Job for tailscaled.service failed because the control process exited with error code.
See “systemctl status tailscaled.service” and “journalctl -xe” for details.

Footage :

Thanks sir

The journalctl output it suggests to run would tell the error it is experiencing. I’d recommend running:

journalctl -u tailscaled --since=“2 hours ago”

Hello sir, thanks for the reply. I try it but got same error sir.

Please run: journalctl -u tailscaled --since=“2 hours ago”
and paste the output.

Don’t record another video of systemd not able to start. The two videos you’ve already sent demonstrate the problem sufficiently.

This the capture output sir
Mar 08 13:52:04 4902ea4b0c99 systemd[1]: Failed to start Tailscale node agent.

log output :

Mar 08 13:51:06 4902ea4b0c99 tailscaled[46069]: is CONFIG_TUN enabled in your kernel? `modprobe tun` failed with: modprobe: FATAL: Module tun not found in directory /lib/modules/5.4.17-2136.300.7.el8uek.aarch64
Mar 08 13:51:06 4902ea4b0c99 tailscaled[46069]: tun module not loaded nor found on disk

Is this a docker container? It does not have a /dev/net/tun device, which Tailscale needs.

In the Dockerfile you can give it access to the host system and the capabilities it would need:

volumes:
  - '/lib/modules:/lib/modules'
  - '/dev/net/tun:/dev/net/tun'
cap_add:
  - net_admin
  - sys_module

Thanks sir, it already solved using auth keys. But i will use that if someday i make my own custom image.