Two tailscale network adapters show in list

hello, thanks,

Windows 11 64bit
tailscale 1.16.2

i tried to disable the tailscale network adapter. got the following message
then at some point i got a pop-up, that tailscale needed to reboot the computer.
unfortunately, the pop-up did not wait long enough for a screenshot, it just went away by itself.

now i have two tailscale adapters.

Does any other user try to remote into the same system? Did you just upgrade and run into this issue?

Does any specific action cause this?



no, i simply disabled the network adapter

well, as i mentioned i tried to disable the network adapter.

note: the second network adapter is gone now.

i have since updated to v1.18.0

note: just now as a test, i disabled the network adapter.
it has disappeared from the network adapter list. cannot find it, cannot re-enable it.

tailscale status
# Health check:
#     - ReceiveDERP is not running
#     - ReceiveIPv4 is not running
#     - ReceiveIPv6 is not running   en08                 asdffdsazqqq@ windows -   bnas                 asdffdsazqqq@ linux   -   server02             asdffdsazqqq@ windows -    vserver03            asdffdsazqqq@ windows -    wsl01                asdffdsazqqq@ linux   -

and now when i try to ping to machines, local on my lan,

tailscale ping server02
timeout waiting for ping reply

tailscale ping bnas
timeout waiting for ping reply

note: i has to re-start the tailscale service and then the network adapter re-appeared and is working.

again, as a test, i disabled the network adaptter and once again, i get


After upgrading to 1.18 were you still getting 2 tailscale adapters?

hello, thanks
so far, just one adapter but that is no longer working,
please see

We have logged the GitHub issue, please subscribe to Two tailscale network adapters show in list and cause error if delete one of them. · Issue #3383 · tailscale/tailscale · GitHub for future updates.