Tailscale on a Chromebook?

Wondering if I’m fighting a losing battle. I have a chromebook which I want to use to connect to my Emby server via Tailscale, like I do from my Android phone and Windows computer. I was able to install and activate Tailscale in a Linux terminal on Chromebook, but when I go back to my Chrome OS browser (Chrome) it will not connect to the Tailscale partner. Just errors with “unable to reach”.

I don’t see any Tailscale native to the Chrome OS, but it seems the session created via the Linux terminal is not recognized at the OS level but rather is limited to the Linux shell. But for what I need to do, I need to reach my Emby server in a web browser, not a terminal session.

Is this just not possible, or am I missing something?

Thanks -

Many Chromebooks are able to run Android apps: Install Android apps on your Chromebook - Chromebook Help

The Tailscale app for Android does support running on Chromebooks.

Wow, that was easy… I knew I must be missing something. I swear I had tried looking for Tailscale directly on the Play store, but using the link from Tailscale’s Android install link worked flawlessly! Thanks!

I installed Tailscale from the Play Store on my chromebook and it works fine when I use a chrome app like Secure Shell, including magic DNS. But when I use the built-in Linux terminal on my chromebook, magic DNS doesn’t seem to work (i.e. it doesn’t recognize my hostname, tho when I type in the IP address, I can ssh to my remote computer just fine). Just pointing it out in case that’s surprising or something you’d like to fix/improve.

Is the Linux terminal crosh, or is it a shell in a Crostini VM?

crosh we might conceivably be able to do something about, if ChromeOS has some nuance in its handling of the Android VpnBuilder which we can tweak.

I don’t expect to have any control over what Crostini does from inside the Tailscale Android app.