Tailscale fails with an error about creating an interface: cannot create a file when that file already exists

image

I have uninstalled, cleared files and reinstalled ut to no effect

This is being tracked in wgengine.NewUserspaceEngine: Error starting session: The system cannot find the path specified · Issue #1792 · tailscale/tailscale · GitHub. It appears to have been triggered by a recent Windows update, builds 21364 and 21370 have both been reported. Are you running one of these?

i can’t tell what build version it is because the program goes away as soon as I click after starting - but I downloaded tailscale-ipn-setup-1.6.0.exe

Can you please share the windows build version you are using? Given snip is for the Tailscale version.

sorry, how would i find that i am not sure I understand

windows 10?

Edition Windows 10 Home
Version 20H2
Installed on ‎2020-‎08-‎01
OS build 19042.928
Experience Windows Feature Experience Pack 120.2212.551.0

Can you please try to delete the Wintun device from your windows10 machine after tailscale uninstall and reinstall the Tailscale? one fo the customer tried this to delete the wintun device : https://www.online-tech-tips.com/computer-tips/unable-delete-network-adapter-windows-10/ incase it helps.

Thanks!! I think that fixed it

there were two wontons i removed both

thanks!

I just hit this after a recently Windows update while running v1.12.3 of Tailscale. Using the URL that @ darshinimashar provided worked great.

The problematic Wintun device was even showing a problem icon over it when I got into the Device Manager. All better :slight_smile: