Tailscale and ESET can't connect to share directory on Windows

just installed 2 windows systems with Tailscale and have them both on my admin page. in my windows 10 system, I have a shared directory called “NAS1” I try to connect from a windows 11 system to that share and I get an error “couldn’t be accessed, no connection” I have tried both the IPs and name method.

my configuration
current updated windows 10, eset firewall, tailscale
current updated windows 11, eset firewall, tailscale

Reproduction steps:
-add windows 10 system to Tailscale
-add windows 11 system to Tailscale
-create a shared directory on windows 10 system called “nas1”
-connect all systems too Tailscale
-open file explorer on windows 11 system and tried to surf to windows 10 share (\100.109.xx.xxx\nas1 and \windows10sys\nas1) and no luck
-open command windows on windows 11 system and tried to ping windows 10 system and it timed out

I have tried removing eset on my window 10 system (the one with the shared directory) and it works. reinstalled eset and get the same failures. however, I can’t see why it is failing or what is being blocked.