Subnet router no longer working on Starlink

I’ve been using TS Subnet Router with Starlink to access my ham station and other devices for about 6 months. I had it running on a headless Pi but suddenly it stopped. I thought it was a problem with the pi, so I disconnected it and created another server on a desktop. It worked for a day but or two, then stopped. I know enough about networking to be dangerous, so I’m at a loss as to what is going on.


What is your default gateway on this subnet? A different device than the TS subnet router?

Both TS and Starlink use the same CIDR block (called CGNAT), so setting up routes can be tricky. Usually, your network will have a default route for everything except local traffic that goes to your gateway. To help you further, it would be good to know what device is routing your internet traffic.

I’m headed out of town for a month so I’ll have to look at it later. Appreciate your input. I think you may have narrowed it down. It’s just odd that it worked for several months.

I also had problems when I used a different device than the default gateway for the TS based routing. It worked, but then it didn’t work, and I had no idea. I wasn’t aware of the CIDR overlap, but I had the chance to move the TS client to the actual router. Since then, it works.